Fei3939の戯言

忘備録とかいろいろ愚痴ったりとか

艦メモをDebian(Wheezy)で動かす

あらまし

自宅PC(Windows機)の電源が爆発してお亡くなりになられたため、
急遽ノートPCにて提督業務を遂行する環境を構築する任務が発生。

候補

以前は艦これ専用ブラウザー Teitoku - geta6 | makeboothを使っていましたが、
改めて導入しようとしてうまく行かず。
そこで、艦メモ ~艦娘メモリーズ~(艦これ専用ブラウザ) - 理ろぐを入れてみました。

環境

Fei3939@debian:~$ uname -a
Linux debian 3.2.0-4-amd64 #1 SMP Debian 3.2.57-3+deb7u2 x86_64 GNU/Linux
Fei3939@debian:~$ cat /etc/debian_version 
7.5

※Flashplayerは既に入っているとします。

手順

基本的にはUbuntuの場合をDebianで読み替えて(読み替えるほどじゃない)行きます。
64bit環境なので、Ubuntu-64bit(deb)からDLします。
つづいて、

$ sudo dpkg -i kanmusumemory-0.0-ubuntu-x86.deb

で、問題はここからでした。

Fei3939@debian:~/Downloads$ KanmusuMemory 
/usr/local/bin/kanmusumemory/KanmusuMemory: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /usr/local/bin/kanmusumemory/KanmusuMemory)
/usr/local/bin/kanmusumemory/KanmusuMemory: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /usr/local/lib/kanmusumemory/libQt0TwitterAPI.so.0)

これGLIBCのversionが2.14以上を要求されてます。
それに気づかずに、シンボリックリンクの貼り付けとか考えてて時間食いました。
結果から言うと、Debian Wheezyのデフォルトのlibc6のversionは2.13なんですね…
libc6 Download (DEB, RPM)←ここ見ると(ノ∀`)アチャーですわ。
しょうがないんで、こっから一番新しいの(書いてる時点では2.19)をDLします。
んでインスコ……

Fei3939@debian:~/Downloads$ sudo dpkg -i libc6_2.19-1_amd64.deb 
dpkg: libc6_2.19-1_amd64.deb が libc6:amd64 を含んでいることを考慮すると:
 libc6:amd64 は locales (<< 2.19) を壊します
  locales (バージョン 2.13-38+deb7u1) が提供され、導入済み です。

dpkg: libc6_2.19-1_amd64.deb の処理中にエラーが発生しました (--install):
 libc6:amd64 のインストールは locales を壊す可能性があり、
 設定削除は許されていません (--auto-deconfigure が助けになります)
処理中にエラーが発生しました:
 libc6_2.19-1_amd64.deb

へー(棒

Fei3939@debian:~/Downloads$ sudo dpkg -i --auto-deconfigure libc6_2.19-1_amd64.deb 
dpkg: `libc6:amd64' のインストール によって壊れた locales の設定削除を考えています ...
dpkg: 問題ありません。(libc6:amd64 によって壊れた) locales の設定削除をします
(データベースを読み込んでいます ... 現在 154242 個のファイルとディレクトリがインストールされています。)
libc6:amd64 2.13-38+deb7u1 を (libc6_2.19-1_amd64.deb で) 置換するための準備をしています ...
locales を設定削除しています ...
Checking for services that may need to be restarted...
Checking init scripts...
libc6:amd64 を展開し、置換しています...
libc6:amd64 (2.19-1) を設定しています ...
Checking for services that may need to be restarted...
Checking init scripts...

Restarting services possibly affected by the upgrade:
  exim4: restarting...done.
  cups: restarting...done.
  cron: restarting...done.
  atd: restarting...done.

Services restarted successfully.
dpkg: 依存関係の問題により locales の設定ができません:
 locales は以下に依存 (depends) します: glibc-2.13-1 ...しかし:
  パッケージ glibc-2.13-1 はまだインストールされていません。
libc6:amd64 (2.19-1) は locales (<< 2.19) を壊し、導入済み です。
設定される locales のバージョン は 2.13-38+deb7u1 です。

dpkg: locales の処理中にエラーが発生しました (--install):
 依存関係の問題 - 設定を見送ります
処理中にエラーが発生しました:
 locales

(もしかしてコケた…???)

Fei3939@debian:~/Downloads$ KanmusuMemory 

f:id:Fei3939:20140609230502p:plain
キタ━━━━(゚∀゚)━━━━!!

お疲れ様でした。